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INTERACTIVE LEARNING IN THE EARLY PHASE - STOP MOTION ANIMATION IN THE CLASSROOM 

MAKE YOUR OWN STOP MOTION ANIMATION 
SEQUENCE WITH WINDOWS MOVIE MAKER 

In this tutorial, you will learn how to  
bring the magic of stop motion animation  
into your Early Phase  classroom.  This is a 
highly engaging and rewarding learning 
activity that: 
 
- provides students with opportunities to  
  draw on their multiple intelligences; 
 
- engages students in creative and logical  
   thinking and problem solving processes; 
 
- can provide students with opportunities to  
  share their ideas and communicate their  
  understandings in a creative way; 
 
- can encourage team work and collaboration between 
  students. 
 
This tutorial is designed to provide you with a chance 
to work through the steps involved in creating a stop 
motion or clay animation sequence.  Once you have seen 
just how easy and rewarding the process is, you will then 
be able to brainstorm ways you can use this process in 
your classroom.   To help you on your way, we have 
included a few ideas in the panel on the right.  These ideas 
have all been implemented in Early Phase classrooms in 
Queensland schools and the feedback from teachers is that 
this a great activity to do with Early Phase students. 
 
What you will need to complete this tutorial 
 
To complete this tutorial, you will need: 
 
•   art supplies such as cardboard, paper, coloured pencils 

  and paint to design the set for your animation; 
 

•   models that can be moved or some plasticine you can  
  use to create your own models; 
 

•   a digital camera; 
 

•   a tripod or a desk or table you can use to mount the 
  digital camera on.  Note that you need to have your 
  camera in the exact same spot when taking the photos 
  in your sequence.   If you do not have access to a 
  tripod, you may need to use blu-tack or tape to  
  keep your camera in the same position; 
 

•   Windows Movie Maker  (available free with Windows 
  XP and Windows Vista). 
 

Ideas for the Early Phase 
Classroom 

 
• Set up a stop motion  

learning centre in a corner 
of your classroom.   Let 
students engage in free  
play as they create their 
own stop motion sequences. 

 
• Have students create stop 

motion sequences that retell 
parts of a story or rhyme. 
 

• Use felt boards and felt 
pieces as the manipulatives 
for your stop motion 
sequences; 
 

• Undertake whole class joint 
constructions of stop motion 
animation sequences as part 
of morning sessions or focus 
lessons; 

 
• Have students work in small 

groups to create stop motion 
sequences based on number 
stories.   
 

• Create stop motion  
sequences on science  
concepts such as life cycles,  
how things move and  
features of the earth and 
sky. 
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The Stop Motion Animation Process 
 
This section of the tutorial is designed to take you 
through the steps involved in creating your own 
stop motion animation sequence.   It will also 
provide you with hints and tips for using the 
process in an Early Phase classroom context. 
 
Step 1.  It all begins with…. 
 
The Stop Motion Animation process always begins 
with either: 
 
a) an idea 
   The idea for the animation sequence  can be   
   generated by an individual student, a teacher or  
   a small or whole class group.   You could ask students to think up an idea for creating  
   a stop motion sequence or brainstorm ideas as a whole class.    or 
 
b) a design brief 
    A design brief sets the parameters for the stop motion animation sequence.   Design 
    briefs are typically provided to the students by a teacher, however could also be 
    given to students by an external client.  For example, a police officer may visit the 
    classroom and provide students with a design brief to create a collection of stop  
    motion animation sequences to teach other children about road safety rules. 
 
    Example design briefs for Early Phase students are shown here. 
 
 
 
 
 
 
Before moving on to the next step, develop an idea for the stop motion animation  
sequence you will create as part of this tutorial.   You may also wish to develop a few  
potential design briefs that would be suitable for use within your current unit of work or 
classroom context. 
 
Step 2.   Brainstorming ideas and planning your animation sequence. 
 
The second step in the stop motion animation process involves brainstorming ideas and 
developing a plan for your animation sequence.   The following should be taken into 
consideration: 
 
• availability of materials; 
• a budget if the teacher has costed materials for them to purchase; 
• how much time they students have to complete the project; 
• what is realistically achievable; 
 
It is a good idea to talk to students about their ideas and planning during this stage to 
ensure their goals for the animation are achievable.  Often students don’t understand 
how time consuming the process can be and this leads them to planning a full length 
feature film narrative, whereas time constraints will usually mean that they only have 
time to make a 10 – 30 second animation. As an indication of the time required, it may 
take around an hour for the students to take 60 individual shots. When stitched 
together, these shots will add up to a short sequence of around 25 seconds. 
 

This diagram shows the steps involved in 
creating a  stop motion animation sequence. 

Make a stop motion  
animation sequence 

that retells a  
nursery rhyme. 

Create a stop  
motion sequence  
on an addition  
number story. 

Make a stop motion 
sequence that 

teaches others about 
a school rule. 

Create an  
animation about a 
letter from the 

alphabet. 
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Before moving on to the next step, ensure you have a clear idea for your animation 
sequence and a plan outlining the types of models and materials you will use and the 
motion that will be depicted in your sequence. 
 
Step 3.  It’s time to create a storyboard 
 
Whilst not an essential part of the process,  this step is a valuable part of the process, 
particularly for older students.   In this step,  students represent their ideas by creating  
drawings and notes.   
 
This is a paper-based part of the process and students can be given a template to use 
or can do rough drawings on plain paper. 
 
Before moving on to the next step, draw your own storyboard on paper. 
 
Step 4.  Making your models and sets 
 
This is the part where the fun begins.   Infact depending on the time you have, it may 
actually be the first step in the process when implementing it in an Early Phase 
Classroom. 
 
It’s time to create the models for your sequence.   Students can use clay to create  
their own models or can use a wide range of different models and manipulatives. 
Popular models used in Early Phase classrooms include: 
 
• Lego characters and pieces; 
• Toys such as dolls, plastic animals, toy cars and 

dinosaurs; 
• Natural materials such as leaves, sand, rocks and  
     sticks; 
• Characters and objects made of felt, coloured card 

or plasticine. 
 
You can limit students to one type of model, however nearly 
anything can be used in this process and the more open-
ended you are, the more students will be able to explore, 
invent and create.   
 
Sets are created in a number of ways.   
Students can create a diorama creating the 
environment for their animation sequence  
or can simply paint or draw a background 
that can be blu-tacked to a wall or board. 
 
A common type of set used in Early Phase 
classrooms is a piece of cardboard that 
is folder in half.  The cardboard is then  
placed on a desk or the floor against a  
wall.  The top half becomes the sky or  
background and the bottom becomes the 
ground or floor of the set. 
 
Before moving on to the next step, make 
sure you have your set and your models 
ready for the animation process. 

Important tip! 
 
Plasticine models 
will melt in the 
hot weather.    
 
If students are going to be working on 
their animation over several days or 
weeks, try to keep plasticine models in 
the fridge in empty plastic containers or 
in an air conditioned room or cupboard. 
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Step 5.  Capturing the Photographs  
 
It’s time to start taking the photographs that will be 
stitched together to create our animation sequence.  
This stage is pretty straightforward, however, there 
are a few rules that need to be followed to ensure 
success. 
 
1) You need to use a digital camera and will have  
    to ensure that your memory stick contains  
    enough space to store a large number of images.  
    You may also wish to check the settings in the  
    menu to ensure that the file resolution isn’t set  
    at the highest quality – this will limit the number  
    of photographs that can fit on your media. 
 
2) A tripod is recommended for this activity. If you  
    don’t have access to one, consider blu-tac or tape  
    as a means of securing your camera to the one place.  
    A quality stop motion animation relies on the camera  
    being set up in the one spot and the frame remaining  
    unchanged for each scene.    
 
3) Once you have your frame set-up and have taken a shot, the camera should not be  
    moved. For this reason, ensure that there is enough space on your memory card and  
    that your batteries are fully charged prior to starting. 
 
4) This process involves the students setting up their scene and model, taking a photo,  
    moving the model slightly and then taking another photo. This process is repeated  
    many times until the students have worked through the action they wish to  
    represent. 
 
5) Note that the flash should not be on during the filming process. The flash will cause  
    light variations in the final animation. Be cautious also of the students leaning over  
    the animation when taking photographs. This can lead to shadows being cast during  
    some photographs and this too will cause light variations. 
 
6) When students are working collaboratively, it is a good idea to assign roles.    
    One student can be the photographer, another the director and another the model  
    mover. This works very well with younger students who tend to rush from one side  
    of the camera to the other – which can lead to the tripod being knocked and the  
    frame being changed.  
 
 
Now that you have an understanding of how 
this process works in a classroom setting, it’s 
time for you to take your photos.    
 
Set up your set, models, tripod and camera 
and begin taking your shots.   Move your 
models slightly for each shot and continue 
the process until you have taken all the shots 
to depict the required motion. 
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Step 6.  Stitching the Animation Sequence together in Windows Movie Maker  
 
Once you have taken all of the photos, it’s time to stitch them together to create the 
animation sequence.   This stage can be completed using a variety of software 
applications including Windows Movie Maker, I-Movie, Quicktime Player, Stop Motion 
Pro and Animation Shop.   
 
In this tutorial, we will be using Windows Movie Maker 2.   The reason for this is that it 
is a free application that comes with Windows XP.    
 
Follow these steps to finish your stop motion animation sequence. 
 
1. Create a new folder on your computer.   To do this, click in the folder or part 

of the network where you would like to create the folder and then right click and 
select New > Folder.   Give the folder a name such as animation. 

 
2.     Save the photos from your camera to the new folder you have created. 
 
3.     Open Windows Movie Maker. 
 
4.     Press the Collections button at the top of Movie Maker. 
        You should now see the Collections Panel shown below appear 
        at the left hand side of the screen. 
 
5.     Select Tools > New Collection from  
        the top menu.   
 
6.     A new collection will appear for you to 
        rename.   Type in a name related to 
        your animation sequence. 
 
7.     Import your photos into your new collection  
        by selecting File > Import into Collections and locating the photographs on 
        your computer. 
 
        Your screen should look 
        similar to this. 
 
8.    We are now going to set up Movie  
       Maker to make each of the photos          in  
       your movie appear for only 0.25  
       of a second.  This will mean that  
       4 photos will be displayed each 
       second and this will create an  
       illusion of motion. 
 
        To do this, select Tools > Options  
        from the top menu.   Select the  
       Advanced tab from the top of  
       the Options panel. 
 
      In the Picture duration box, change 
       the duration to 0.250 seconds. 
       
      ** This must be done prior to   
      dragging the images onto the timeline. 
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9.  Select all of the images in the collection by clicking in the collection and pressing 
     Ctrl + A.   Drag the images down into the storyboard at the bottom. 
 
  
      
 
 
 
 
 
 
10.  Press the Play button to preview the animation.   If your animation is smooth 
       and you are happy with the speed, move on to the next step.   If it is too fast, 
       press undo until the pictures are removed from the storyboard and then 
       adjust the Picture duration setting. 
 
11.   Finish your animation sequence by adding some titles and credits.   To do this 
       select Tools > Titles and Credits and set up the titles and credits using the 
       options provided. 
 
12.   You can also add sound to your animation sequence by using the Narration 
        feature.  To add narration to your animation, select the Narrate Timeline 
         button and select Start and Stop Narration to capture your narration. 
 
        You can also add sound by importing an existing sound file.  To do this, select 
        File > Import into Collections and select the file you wish to use.   Click on  
        the Show Timeline button above the Storyboard and then drag the sound file 
        onto the Audio / Music layer of the timeline. 
          
13.   Your stop motion animation sequence should now be complete. 
 
        Select File > Save Project As to save your Moviemaker file.   This is the file 
        you can open to edit your animation sequence.    
 
        Select File > Save Movie File to export your animation in a format that can be 
        viewed on any computer.   Click the appropriate settings – usually saving to view  
        on your computer – and complete this process. 
 
14.   View your animation and share your animation with your class and colleagues. 
 
Step 7.   It’s time to share your work 
 
The final step involves sharing the animation sequences you or your students have 
created with others.    You could: 
 
- Select the email setting when saving the movie file in Movie Maker and then email 
  the animated films to parents; 
 
- Invite parents or other classes in to view the animations as part of an Animation 
   Festival; 
 
- Upload the animations to the school or class website. 
 
If you’ve reached this point, you’ve more than likely mastered the process of making a 
stop motion animation sequence.    Check out our Interactive Learning in the Early 
Phase website to see some great ideas and examples of how it can work in your Early 
Phase classroom. 


